发布网友 发布时间:2024-09-28 16:14
共1个回答
热心网友 时间:1分钟前
R1>en
R1#sh run
Building configuration...
Current configuration : 741 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.3.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 192.168.3.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 1
default-information originate
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.2
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line vty 0 4
login
!
!
!
end
R2#sh run
Building configuration...
Current configuration : 665 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.3.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.4.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
redistribute rip metric 200 subnets tag 200
network 192.168.3.0 0.0.0.255 area 0
!
router rip
version 2
redistribute ospf 1 metric 10
network 192.168.4.0
no auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
R3#sh run
Building configuration...
Current configuration : 663 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
redistribute static metric 100 subnets tag 100
redistribute connected
network 192.168.1.0 0.0.0.255 area 1
!
ip classless
ip route 100.1.1.0 255.255.255.0 192.168.2.2
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line vty 0 4
login
!
!
!
end
R4#sh run
Building configuration...
Current configuration : 512 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R4
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 100.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.2.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
R5#sh run
Building configuration...
Current configuration : 555 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R5
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 200.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.4.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
router rip
version 2
network 192.168.4.0
network 200.1.1.0
no auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
ISP#sh run
Building configuration...
Current configuration : 517 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ISP
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 202.100.110.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.5.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.5.1
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end